Articles / Red Hat: An updated nfs-uti…

Red Hat: An updated nfs-utils-lib package corrects a security flaw

The nfs-utils-lib package contains support libraries that are needed by the commands and daemons of the nfs-utils package. Tenable Network Security discovered a stack buffer overflow flaw in the RPC library used by nfs-utils-lib. A remote unauthenticated attacker who can access an application linked against nfs-utils-lib could trigger this flaw and cause the application to crash. On Red Hat Enterprise Linux 4 it is not possible to exploit this flaw to run arbitrary code as the overflow is blocked by FORTIFY_SOURCE. Fixed packages are available from updates.redhat.com.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- ---------------------------------------------------------------------
                   Red Hat Security Advisory

Synopsis:          Important: nfs-utils-lib security update
Advisory ID:       RHSA-2007:0913-01
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2007-0913.html
Issue date:        2007-09-19
Updated on:        2007-09-19
Product:           Red Hat Enterprise Linux
CVE Names:         CVE-2007-3999 
- ---------------------------------------------------------------------

1. Summary:

An updated nfs-utils-lib package to correct a security flaw is now
available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AS version 4 - i386, ia64, ppc, s390, s390x, x86_64
Red Hat Enterprise Linux Desktop version 4 - i386, x86_64
Red Hat Enterprise Linux ES version 4 - i386, ia64, x86_64
Red Hat Enterprise Linux WS version 4 - i386, ia64, x86_64

3. Problem description:

The nfs-utils-lib package contains support libraries that are needed by the
commands and daemons of the nfs-utils package.

Tenable Network Security discovered a stack buffer overflow flaw in the RPC
library used by nfs-utils-lib. A remote unauthenticated attacker who can
access an application linked against nfs-utils-lib could trigger this flaw
and cause the application to crash. On Red Hat Enterprise Linux 4 it is not
possible to exploit this flaw to run arbitrary code as the overflow is
blocked by FORTIFY_SOURCE. (CVE-2007-3999)

Users of nfs-utils-lib are advised to upgrade to this updated package,
which contains a backported patch that resolves this issue.

4. Solution:

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.  

This update is available via Red Hat Network.  Details on how to use 
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

5. Bug IDs fixed (http://bugzilla.redhat.com/):

250973 - CVE-2007-3999 krb5 RPC library buffer overflow

6. RPMs required:

Red Hat Enterprise Linux AS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4AS/en/os/SRPMS/nfs-utils-lib-1.0.6-8.z1.src.rpm
6de4df5245856abfb1e27f43ec995ad4  nfs-utils-lib-1.0.6-8.z1.src.rpm

i386:
ad7d44ae0fecc5fa1f7f69d20f24d0c2  nfs-utils-lib-1.0.6-8.z1.i386.rpm
d3c267fa989d0835ef1f05f9d65c78b7  nfs-utils-lib-debuginfo-1.0.6-8.z1.i386.rpm
acb8da85e6780111d86eb45182d6926f  nfs-utils-lib-devel-1.0.6-8.z1.i386.rpm

ia64:
6866d2ae4650b96f925384ecf4b6891c  nfs-utils-lib-1.0.6-8.z1.ia64.rpm
1ef19760de6815aa6ed58b455518042a  nfs-utils-lib-debuginfo-1.0.6-8.z1.ia64.rpm
65fbf40e86f97368f5679da2140e0360  nfs-utils-lib-devel-1.0.6-8.z1.ia64.rpm

ppc:
1bd2cf61e4e41a20c11c038bc6895243  nfs-utils-lib-1.0.6-8.z1.ppc.rpm
fd48271663e2641f72c175f4900a1ce2  nfs-utils-lib-debuginfo-1.0.6-8.z1.ppc.rpm
a030703d3d2731eaf4b6573130e562cf  nfs-utils-lib-devel-1.0.6-8.z1.ppc.rpm

s390:
1eaaca7f9b503f611203cc2ab946950f  nfs-utils-lib-1.0.6-8.z1.s390.rpm
fb099cca3862d0cc27018b4b3b2253f2  nfs-utils-lib-debuginfo-1.0.6-8.z1.s390.rpm
f77020fcc2aea3bb5cdeedd3977feb97  nfs-utils-lib-devel-1.0.6-8.z1.s390.rpm

s390x:
a8bab89128f0a7779e929bc6d712a28a  nfs-utils-lib-1.0.6-8.z1.s390x.rpm
3ee0e87b350127174a4f97de1c92d030  nfs-utils-lib-debuginfo-1.0.6-8.z1.s390x.rpm
dff59782eda7f14c789b55254422d3a5  nfs-utils-lib-devel-1.0.6-8.z1.s390x.rpm

x86_64:
fb0cbb12869dadcf9872375bd50012db  nfs-utils-lib-1.0.6-8.z1.x86_64.rpm
b00a1a022f8f714c25c7d5153ec20423  nfs-utils-lib-debuginfo-1.0.6-8.z1.x86_64.rpm
506a8209ed65baa42d147dc0e6503ff5  nfs-utils-lib-devel-1.0.6-8.z1.x86_64.rpm

Red Hat Enterprise Linux Desktop version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4Desktop/en/os/SRPMS/nfs-utils-lib-1.0.6-8.z1.src.rpm
6de4df5245856abfb1e27f43ec995ad4  nfs-utils-lib-1.0.6-8.z1.src.rpm

i386:
ad7d44ae0fecc5fa1f7f69d20f24d0c2  nfs-utils-lib-1.0.6-8.z1.i386.rpm
d3c267fa989d0835ef1f05f9d65c78b7  nfs-utils-lib-debuginfo-1.0.6-8.z1.i386.rpm
acb8da85e6780111d86eb45182d6926f  nfs-utils-lib-devel-1.0.6-8.z1.i386.rpm

x86_64:
fb0cbb12869dadcf9872375bd50012db  nfs-utils-lib-1.0.6-8.z1.x86_64.rpm
b00a1a022f8f714c25c7d5153ec20423  nfs-utils-lib-debuginfo-1.0.6-8.z1.x86_64.rpm
506a8209ed65baa42d147dc0e6503ff5  nfs-utils-lib-devel-1.0.6-8.z1.x86_64.rpm

Red Hat Enterprise Linux ES version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4ES/en/os/SRPMS/nfs-utils-lib-1.0.6-8.z1.src.rpm
6de4df5245856abfb1e27f43ec995ad4  nfs-utils-lib-1.0.6-8.z1.src.rpm

i386:
ad7d44ae0fecc5fa1f7f69d20f24d0c2  nfs-utils-lib-1.0.6-8.z1.i386.rpm
d3c267fa989d0835ef1f05f9d65c78b7  nfs-utils-lib-debuginfo-1.0.6-8.z1.i386.rpm
acb8da85e6780111d86eb45182d6926f  nfs-utils-lib-devel-1.0.6-8.z1.i386.rpm

ia64:
6866d2ae4650b96f925384ecf4b6891c  nfs-utils-lib-1.0.6-8.z1.ia64.rpm
1ef19760de6815aa6ed58b455518042a  nfs-utils-lib-debuginfo-1.0.6-8.z1.ia64.rpm
65fbf40e86f97368f5679da2140e0360  nfs-utils-lib-devel-1.0.6-8.z1.ia64.rpm

x86_64:
fb0cbb12869dadcf9872375bd50012db  nfs-utils-lib-1.0.6-8.z1.x86_64.rpm
b00a1a022f8f714c25c7d5153ec20423  nfs-utils-lib-debuginfo-1.0.6-8.z1.x86_64.rpm
506a8209ed65baa42d147dc0e6503ff5  nfs-utils-lib-devel-1.0.6-8.z1.x86_64.rpm

Red Hat Enterprise Linux WS version 4:

SRPMS:
ftp://updates.redhat.com/enterprise/4WS/en/os/SRPMS/nfs-utils-lib-1.0.6-8.z1.src.rpm
6de4df5245856abfb1e27f43ec995ad4  nfs-utils-lib-1.0.6-8.z1.src.rpm

i386:
ad7d44ae0fecc5fa1f7f69d20f24d0c2  nfs-utils-lib-1.0.6-8.z1.i386.rpm
d3c267fa989d0835ef1f05f9d65c78b7  nfs-utils-lib-debuginfo-1.0.6-8.z1.i386.rpm
acb8da85e6780111d86eb45182d6926f  nfs-utils-lib-devel-1.0.6-8.z1.i386.rpm

ia64:
6866d2ae4650b96f925384ecf4b6891c  nfs-utils-lib-1.0.6-8.z1.ia64.rpm
1ef19760de6815aa6ed58b455518042a  nfs-utils-lib-debuginfo-1.0.6-8.z1.ia64.rpm
65fbf40e86f97368f5679da2140e0360  nfs-utils-lib-devel-1.0.6-8.z1.ia64.rpm

x86_64:
fb0cbb12869dadcf9872375bd50012db  nfs-utils-lib-1.0.6-8.z1.x86_64.rpm
b00a1a022f8f714c25c7d5153ec20423  nfs-utils-lib-debuginfo-1.0.6-8.z1.x86_64.rpm
506a8209ed65baa42d147dc0e6503ff5  nfs-utils-lib-devel-1.0.6-8.z1.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and 
details on how to verify the signature are available from
https://www.redhat.com/security/team/key/#package

7. References:

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3999
http://www.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is .  More contact
details at https://www.redhat.com/security/team/contact/

Copyright 2007 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFG8VyNXlSAg2UNWIIRAqJtAJ9oIrCvscZWyQn8Ya0Tse/ViWm8uACfem6D
yJV7J8AqWNfMBbmHcJZWRvQ=
=1s6X
-----END PGP SIGNATURE-----
Screenshot

Project Spotlight

Kigo Video Converter Ultimate for Mac

A tool for converting and editing videos.

Screenshot

Project Spotlight

Kid3

An efficient tagger for MP3, Ogg/Vorbis, and FLAC files.